Recently I rebuilt my PC and reinstalled windows. I think I may have posted a bit about the crap that was going on. Anyway, when I did, I installed the Windows XP 64 bit version in order to take full advantage of my CPU. There are a few drivers that will no longer work, such as my scanner, and my cell phone USB cable. No big deal, I can live with that. I moved the scanner over to Stephanie’s PC, and will just live with the fact that I can’t transfer the shit off of my phone. About the only thing that I couldn’t get to install and work properly was iTunes, and Quicktime, which pisses me off to no end. I did a bunch of searching on the Apple site, as well as other places, all of which came to no avail. Apple won’t support the 64 bit version of Windows XP. Fine, fuck you.

I then put Windows Vista Beta 2 on there, running a dual boot system. I had a few problems with my sound card and network card, but just swapped those out with some others from my basement that are compatible with both OSes. No problems there. There are a few glitches, I have a hard time processing converting DVD’s to Divx under Vista, right now I am running under XP to convert a couple so that I can send them back to Netflix and watch later. For the most part, I really like Vista. This is the first time I have even rebooted to XP in a couple of weeks.

The big kicker is that iTunes and Quicktime install under the 64 bit version of Vista with NO PROBLEM. Not only that, but they run just fine. Ok, so what the fuck is the deal? Apple, you are a bunch of fucking assholes. I started iTunes a couple of days ago and got the message that there was an update, so I downloaded it and tried to install. It gives me a message that iTunes will only install on 32 bit versions of Windows 2000 and XP. What the fuck? Is that the purpose of the fucking upgrade? You guys want to be assholes about what you have to support? It’s not like I have ever called you for support, and then only two times that I have tried to get Quicktime support (yes, I am a registered Quicktime Pro owner) nobody ever bothered to fucking reply anyway.

Software designers need to leave a loophole in their installation routines, such as advanced installation, so that assholes like me that want to fuck up their systems, can install their software on unsupported systems.

Maybe if I try to run it in compatibility mode that will work. Vista will still not report itself as being XP, but I have done this in the past with other stuff and it has worked.


Technorati : , , , , ,

Advertisements